viernes, 23 de agosto de 2013

VMware no me instala en Fedora 19 con kernel 3.10.x, esto puede ayudarte.

z

Bien si mal no recuerdo VMware logra funcionar bien 3.5.x entonces por ende ahora que estamos por los lados del kernel 3.10.x simplemente nos JODIMOS!!! O_o pero gracias a alguien de EU (al final dejo la fuente de la información) resolví el problema que son unos fáciles pasos.



$ cd /tmp ==> Como usuario normal.
$ curl -O http://pkgbuild.com/git/aur-mirror.git/plain/vmware-patch/vmblock-9.0.2-5.0.2-3.10.patch ==> Descarga Modulo 1.
$ curl -O http://pkgbuild.com/git/aur-mirror.git/plain/vmware-patch/vmnet-9.0.2-5.0.2-3.10.patch ==> Descarga modulo 2.
$ cd /usr/lib/vmware/modules/source ==> Vamos a la carpeta carpeta de los módulos ( codigos ) de vmware.
# tar -xvf vmblock.tar ==> Como root ( Administrador Linux ) descomprimir modulo 1.
# tar -xvf vmnet.tar ==> Como root ( Administrador Linux ) descomprimir modulo 2.
# patch -p0 -i /tmp/vmblock-9.0.2-5.0.2-3.10.patch ==> Actualizar e instalarlo.
# patch -p0 -i /tmp/vmnet-9.0.2-5.0.2-3.10.patch ==> Actualizar e instalarlo.
# tar -cf vmblock.tar vmblock-only ==> Comprimir modulo.
# tar -cf vmnet.tar vmnet-only ==> Comprimir modulo.
# rm -r vmblock-only ==> Borrar instalador de modulo.
# rm -r vmnet-only ==> Borrar instalador de modulo.
# vmware-modconfig --console --install-all ==> Compilar e instalar vmware con sus módulos  de nuevo.


Y santo remedio, ahora ya puedes utilizar VMware hasta que ellos arreglen este bug que tienen, espero les allá servido para algo esto, Dios los bendiga.


Fuente

Publicar un comentario